ORA-16766: Redo Apply is stopped
I. description of the environment
Oracle 12caix 7.1
Second, the question
MRP process failed to start, error ORA-16766
1. View database status
DGMGRL > * * show database verbose orcldg * * Database-orcldg Role: PHYSICAL STANDBY Intended State: APPLY-ON Transport Lag: 3 days 12 hours 25 minutes 24 seconds (computed 75 seconds ago) Apply Lag: 3 days 12 hours 25 minutes 41 seconds (computed 75 seconds ago) Average Apply Rate: 361.00 KByte/s Active Apply Rate: (unknown) Maximum Apply Rate: 340.77 MByte/s Real Time Query: OFF Instance (s): orcldg Database Error (s): * * ORA-16766: Redo Apply is stopped** Database Warning (s): ORA-16857: standby disconnected from redo source for longer than specified threshold
two。 Attempt to start the MRP process
DGMGRL > edit database 'orcldg' set state='apply-on'; Succeeded.DGMGRL >
3. View the recovery process
SQL > * * select process,status from v$managed_standby * * PROCESS STATUS---ARCH CLOSINGARCH CONNECTEDARCH CLOSINGARCH CLOSINGRFS IDLE
4. View the log
SQL > * * select message from v$dataguard_status * * MESSAGE- -Creating archive destination file: + DATADG (1463121 blocks) Creating archive destination file: + DATADG (1479835 blocks) Creating archive destination file: + DATADG (1494118 blocks) Creating archive destination file: + DATADG ( 1505856 blocks) Creating archive destination file: + DATADG (1480255 blocks). Creating archive destination file: + DATADG (1489779 blocks) Creating archive destination file: + DATADG (1486756 blocks) Creating archive destination file: + DATADG (1444692 blocks) Creating archive destination file: + DATADG (844053 blocks) MESSAGE - -- Media Recovery Log + DATADG/COREDG/ARCHIVELOG/2017_11_28/thread_1_seq_1770.1375.961232949Media Recovery Log + DATADG/COREDG/ARCHIVELOG/2017_11_28/thread_2_seq_1163.1201.961232061MRP0: Background Media Recovery terminated with error 1237Managed Standby Recovery not using Real Time ApplyMRP0: Background Media Recovery process shutdownAttempt to start background Managed Standby Recovery processMRP0: Background Managed Standby Recovery process startedManaged Standby Recovery starting Real Time ApplyMedia Recovery Log + DATADG/COREDG/ARCHIVELOG/2017_11_28/thread_1_seq_1770.1375.961232949Media Recovery Log + DATADG/COREDG/ARCHIVELOG/2017_11_28/thread_2_seq_1163.1201.961232061MRP0: Background Media Recovery terminated with error 1237MESSAGE Murray- - -Managed Standby Recovery not using Real Time ApplyMRP0: Background Media Recovery process shutdownCreating archive destination file: + DATADG (1685417 blocks)
5. Unable to create file to view disk group space
ASMCMD > lsdgState Type Rebal Sector Block AU Total_MB Free_MB Req_mir_free_MB Usable_file_MB Offline_disks Voting_files NameMOUNTED NORMAL N 512 4096 1048576 153600 153412 51200 51106 0 N CRSDG/MOUNTED EXTERN N 512 4096 1048576 1024000 128 0 * * 128 * 0 N DATADG/ASMCMD >
Third, the treatment method
Delete some archive logs, free up space, and then start the MRP process
Rman target / delete archivelog all;DGMGRL > * * edit database 'orcldg' set state='apply-on'; * * Succeeded.DGMGRL >