[giant sequoia database Sequoiadb] after creating the cataloging group, get the error report of the cataloging group
[problem description]
After creating a catalog group, get an error report from the catalog group
Db.createCataRG ("sdbserver1", 11800, "/ opt/sequoiadb/database/cata/11800")
> var cataRG = db.getRG ("SYSCatalogGorup")
(shell): 1 uncaught exception:-222
RouteID is different from the local
> var cataRG = db.getRG ("SYSCatalogGorup")
(shell): 1 uncaught exception:-104
Node is not primary
[solution]
1. Check whether the hostname has been modified after the node is created. For example, if the hostname of the node is not consistent with the current hostname, it needs to be modified to the hostname of the node when it was created.
two。 This problem is due to the fact that the user hostname is sdbserver1.vmver.test, and when you create a node using sdbserver1, you can access the local machine through DNS (known through dig hostname), thus creating a node named sdbserver1:11800, but the communication between nodes uses the full hostname, so the node cannot be used properly, so you need to re-specify the complete hostname to create the node.