Nginx mainline version 1.15.4 release update description and download address
Nginx mainline version 1.15.4 has been released with a new feature-the "ssl_early_data" directive that can now be used with OpenSSL. Other changes and bug fixes are also included. Nginx (pronounced engine x) is a lightweight Web server / reverse proxy server and email (IMAP/POP3) proxy server, distributed under a BSD-like protocol, and can run on operating systems such as UNIX, GNU/Linux, BSD, Mac OS X, Solaris, and Microsoft Windows.
Feature: now the "ssl_early_data" directive can be used with OpenSSL.
Bugfix: in the ngx_http_uwsgi_module.
Bugfix: connections with some gRPC backends might not be cached when using the "keepalive" directive.
Bugfix: a socket leak might occur when using the "error_page" directive to redirect early request processing errors, notably errors with code 400.
Bugfix: the "return" directive did not change the response code when returning errors if the request was redirected by the "error_page" directive.
Bugfix: standard error pages and responses of the ngx_http_autoindex_module module used the "bgcolor" attribute, and might be displayed incorrectly when using custom color settings in browsers.
Change: the logging level of the "no suitable key share" and "no suitable signature algorithm" SSL errors has been lowered from "crit" to "info"
download address:
http://nginx.org/en/download.html
Update description:
http://nginx.org/en/CHANGES