Some problems with hive
Hadoop client/hive client to connect to HDI on Microsoft Cloud Azure to report an error:
Hive-service metastore
Exception in thread "main" org.apache.thrift.transport.TTransportException: Could not create ServerSocket on address 0. 0. 0. 0.
Getting MissingTableException: Required table missing VERSION when starting hive on mysql
The root cause is that HDI is used here.
1. Both configuration files are changed (there is a difference between centos and ubuntu)
# vim / usr/hdp/2.2.0.0-2041/hive/conf/hive-site.xml
# vim / etc/hive/conf/hive-site.xml
Hive.metastore.warehouse.dir / hive/warehouse location of default database for the warehouse hive.metastore.uris thrift://headnodehost:9083 Thrift URI for the remote metastore. Used by metastore client to connect to remote metastore.
2. Modify hosts
Vim / etc/hosts
The content is from the configuration on HDI's windows machine.
10.0.2.7 headnodehost # SlaveNodeManager 10.0.2.7 jobtrackerhost # SlaveNodeManager 10.0.2.7 namenodehost # SlaveNodeManager
An error is reported by an ordinary hive user:
1. Report an error
Booting Derby (version The Apache Software Foundation-Apache Derby-10.10.1.1-(1458268)) instance a816c00e-0154-2ed3-cbb2-00000e1ebc98
On database directory / var/lib/hive/metastore/metastore_db in READ ONLY mode with class loader sun.misc.Launcher$AppClassLoader@7cc355be.
Loaded fromfile:/usr/hdp/2.2.0.0-2041/hive/lib/derby-10.10.1.1.jar.
Problem: obviously metastore database read only, no write permission
Solution:
# cd / var/lib/hive/metastore/
# chmod-R aquiw metastore_db/
2. The error is as follows, but hive came in anyway
Booting Derby version The Apache Software Foundation-Apache Derby-10.10.1.1-(1458268): instance a816c00e-0154-3155-87b8-00000e0b5a08
On database directory / var/lib/hive/metastore/metastore_db with class loader sun.misc.Launcher$AppClassLoader@7cc355be
Loaded from file:/usr/hdp/2.2.0.0-2041/hive/lib/derby-10.10.1.1.jar
Java.vendor=Oracle Corporation
Java.runtime.version=1.8.0_51-b16
User.dir=/var/lib/hive
Os.name=Linux
Os.arch=amd64
Os.version=2.6.32-573.1.1.el6.x86_64
Derby.system.home=null
Database Class Loader started-derby.database.classpath=''
Hive >
>
Or permission issues: / var/lib/hive# chown-R hive:hive metastore/