Get the App
SLTechnology News&Howtos  ›  Database  › 

Oracle snooping startup failed to connect

Shulou Source: shulou.com Published: 2022-06-01 12:09:27 10月03日 Update

Phenomenon

Remote client toad connection, jam no response. Oracle server using tnsping {ip address} prompt unable to connect.

Check the listener.ora (path F:\ app\ Administrator\ product\ 11.2.0\ dbhome_1\ NETWORK\ ADMIN\ listener.ora) path according to the actual installation path; check the configuration file configuration (ADDRESS = (PROTOCOL = TCP) (HOST = HOSTNAME) (PORT = 1521))

The configured HOST is also a computer name, not a dynamic ip

Try to restart the OracleOraDb11g_home1TNSListener service, reconnect, and check whether the corresponding listening log file is too large, actually only a few K. It is suspected that there is a computer with the same computer name under the same working group (workgroup). Modify the local computer name, modify the computer name in the configuration file, including listener.ora and tnsnames.ora configuration files. Restart the computer and use tnsping {ip address} to check and return the result. The client attempted to connect and connected successfully. Useful tools can be used in cmd to view the status of the listening service using sqlplus to enter the database to operate show parameter listen to view the configuration of monitoring in the database alter system set local_listener=' (ADDRESS = (PROTOCOL = TCP) (HOST = computer name) (PORT = 1521))'(modify the parameters in the listening configuration list, the parameters in quotation marks are only used as samples)

Tags: Configuration computer monitoring file path prompt service check parameter name address actual customer client data database computer problem attempt success Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Linux Microsoft vpn NVidia MySQL