ORA-00600 [kcratr_nab_less_than_odr] troubleshooting
Such errors may occur when the server power supply suddenly fails (using backup control files for recovery)
Type of error:
SQL > alter database open*ERROR at line 1:ORA-00600: internal error code, arguments: [kcratr_nab_less_than_odr], [1], [23], [81], [189]
Solution:
1. View the control file location and the online redo log files currently used by oracle
SQL > Show parameter control_files NAME TYPE VALUE-- control_files string D:\ APP\ MAZAR\ ORADATA\ ORCL\ CONTROL01.CTL, D:\ APP\ MAZAR\ FLASH_RECOVERY_AREA\ ORCL\ CONTROL02.CTLSQL > select a.membermera.group# B.status from v$logfile a, v$log b where a.group#=b.group# and b. StatusThe current MEMBER----GROUP# STATUS--D:\ APP\ MAZAR\ ORADATA\ ORCL\ REDO02.LOG2 CURRENT
two。 Close the database and back up the control file
C:\ Windows\ system32 > COPY D:\ APP\ MAZAR\ ORADATA\ ORCL\ CONTROL01.CTL D:\ APP1 file (s) copied.
3. Mount the database and recover using the control log and the online redo log
SQL > recover database using backup controlfile until cancel;ORA-00279: change 1460665 generated at 10 ORCL 08:38:00 needed for threadORA-00289: suggestion: d:\ APP\ MAZAR\ FLASH_RECOVERY_AREA\ ORCL\ ARCHIVELOG\ 2012 October 14\ O1_MF_1_23_%U_.ARORA-00280: change 1460665 for thread 1 is in sequence # 23Specify log: {= suggested | filename | AUTO | CANCEL} D:\ APP\ MAZAR\ ORADATA\ ORCL\ REDO02.LOGLog applied.Media recovery complete.
4. Open the database and reset the log file
SQL > alter database open resetlogs;Database altered.
Reference document:
Http://mohamedazar.com/2012/10/14/ora-00600-kcratr_nab_less_than_odr-when-alter-database-open-fails/