Get the App
SLTechnology News&Howtos  ›  Internet Technology  › 

What about Exhausted available authentication methods when CDH5 reports an error?

Shulou Source: shulou.com Published: 2022-06-01 00:53:31 10月03日 Update

Most people don't understand the knowledge points of this article "CDH5 Error Exhausted Available authentication methods", so Xiaobian summarizes the following contents for everyone. The contents are detailed, the steps are clear, and they have certain reference value. I hope everyone can gain something after reading this article. Let's take a look at this article "CDH5 Error Exhausted Available authentication methods".

1. Machine environment:

CDH5 throws the error "Exhausted available authentication methods" during installation, where the machine thrown is the new machine made by the mirror of the operation and maintenance environment from the stage machine.

2. What went wrong:

During the installation of CDH5, after entering the hadoop user and password for the next step (cluster installation), the web starts to refresh the data source throwing errors: Exhausted available authentication methods

#Since there was no screenshot at the time, I found a picture on a post afterwards

3. Solution:

a. Check whether the hadoop user configures sudo without password permission successfully.

Click here to fold or open

[root@alish2-xxx-01 ~]# adduser hadoop

[root@alish2-xxx-01 ~]# passwd hadoop

Changing password for user hadoop.

New password:

BAD PASSWORD: it is too short

BAD PASSWORD: is too simple

Retype new password:

passwd: all authentication tokens updated successfully.

[root@alish2-logshedcldmanager-01 etc]# vi /etc/sudoers

## Allow root to run any commands anywhere

root ALL=(ALL) ALL

hadoop ALL=(root)NOPASSWD:ALL

###Verify sudo permissions

[root@alish2-xxx-01 etc]# sudo su hadoop

[hadoop@alish2-logshedcldmanager-01 ~]$ sudo ls -l /root

total 4

-rw------- 1 root root 8 Apr 2 09:45 dead.letter

b. Check if SSH service is normal???

Click here to fold or open

[root@alish2-xxx-01 ~]# service sshd restart

Stopping sshd: [ OK ]

Starting sshd: [ OK ]

#Restart the service directly, then click "retry" and it's OK.

The above is the content of this article about "CDH5 Error Exhausted Available authentication methods". I believe everyone has a certain understanding. I hope the content shared by Xiaobian will be helpful to everyone. If you want to know more relevant knowledge content, please pay attention to the industry information channel.

Tags: Content machine how to do password article permission environment user knowledge article process service check success value picture most that is screenshot data Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Shulou Technology Redmi NVidia Docker macOS