Metasploit Learning 3.2 Service scanning and checkpointing
1. Scan the service version
Msf > search name:_version # scanning service version msf > search name:_login # password guess
-
List of common services
Scan Telnet services
Scan SSH services
Scan Oracle services
-
(1) scan the Oracle network service port
Auxiliary/scanner/oracle/tnslsnr_version
Of course, oracle integrates the most common * * including injection, enumeration, password guessing, and so on.
-
4. Open agent detection and utilization
Using open_proxy module
Msf > use auxiliary/scanner/http/open_proxy
-
Second, counterpart command guessing and sniffing
Guessing of 1.SSH Service password
Auxiliary/scanner/ssh/ssh_login
-
2.SSH password sniffing
It can only be used when the target computer uses the FTP access command, otherwise, it is invalid and all kinds of errors are reported.
Auxiliary/sniffer/psnuffle
Third, vulnerability scanning
Openvas usage
Configuration steps: (the previous configuration is all basic on the Internet, and only some "pits" are explained)
Openvasad-c 'add_user'-n admin-r' Admin'
Pit 1: if you make a mistake, try this: remove the quotation marks
Root@bt:~# openvasad-c add_user-n admin-r AdminEnter password: ad main:MESSAGE:1972:2017-04-21 23h69.46 EDT: No rules file provided, the new user will have no restrictions.ad main:MESSAGE:1972:2017-04-21 23h69.46 EDT: User admin has been successfully
-
Pit 2: unable to connect to GSA?
You have to configure:
Gsad-listen=0.0.0.0-port=9392-alisten=127.0.0.1-aport=9393-mlisten=127.0.0.1-mport=9390-http-only
-
Pit 3: login error:
Either the password is wrong, or you forget to start the plug-in
Root@bt:~# openvassd-listen=127.0.0.1-port=9391
Forget it, the scan results are touching, no loopholes, 666. No more pictures will be posted.
-
Pit 4:msf built-in call to openvas failed
[-] Error while running command openvas_connect: No route to host-connect (2)
The login address was changed to your own ipv4 address 192.168.1.x instead of 127.0.0.1
-
Pit 5: no result of scan
If your openvas self-test is normal (check command used in case of misconfiguration), no error is reported, the port connection is normal, the database has been updated, and you are told that it has been run successfully
But the final scan (metasploit target) has no loopholes, so please try to uninstall and reinstall, at least after I reinstall it, it can be used normally. (I will try the solution again in the near future)