Get the App
SLTechnology News&Howtos  ›  Database  › 

How to solve a mistake of mysql innobackupex

Shulou Source: shulou.com Published: 2022-05-31 16:10:33 10月03日 Update

In this issue, the editor will bring you how to solve a mistake about mysql innobackupex. The article is rich in content and analyzes and narrates it from a professional point of view. I hope you can get something after reading this article.

-bash-3.2 $. / innobackupex-- version-check / usr/mysql/xtraback/xtrabackup03

InnoDB Backup Utility v1.5.1-xtrabackup

150930 17:16:26 innobackupex: Executing a version check against the server...

150930 17:16:26 innobackupex: Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_group=xtrabackup' (using password: NO).

Innobackupex: got a fatal error with the following stacktrace: at. / innobackupex line 3006

Main::mysql_connect ('abort_on_error', 1) called at. / innobackupex line 1551

Innobackupex: Error: Failed to connect to MySQL server as DBD::mysql module is not installed at. / innobackupex line 3006.

150930 17:16:26 innobackupex: Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_group=xtrabackup' (using password: NO).

Innobackupex: got a fatal error with the following stacktrace: at. / innobackupex line 3006

Main::mysql_connect ('abort_on_error', 1) called at. / innobackupex line 1570

Innobackupex: Error: Failed to connect to MySQL server as DBD::mysql module is not installed at. / innobackupex line 3006.

Report such a mistake. The reason for this error is that innobackupex is written in Perl, and perl is executed by calling the mysql database through the perl DBI module and the DBD-mysql module.

Therefore, you need to install the package perl-DBD-MySQL. When you install this package, you will encounter an error:

Yum install perl-DBD-MySQL . Using this command to install will result in the following error:

Transaction Check Error:

File / etc/my.cnf from install of mysql-5.0.77-4.el5_5.4.i386 conflicts with file from package MySQL-server-5.6.25-1.linux_glibc2.5.i386

The reason: perl-DBD-MySQL corresponds to version 5.0 of mysql, while you install version 5.6 of mysql. The workaround is to install DBD manually.

The above is the editor for you to share a mysql innobackupex error how to solve, if there happen to be similar doubts, you might as well refer to the above analysis to understand. If you want to know more about it, you are welcome to follow the industry information channel.

Tags: Error content reason module version analysis specialty small and medium rich content method command that is manual data database article more knowledge article industry Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Xiaomi Linux Shulou Tech Info Huawei MariaDB