Get the App
SLTechnology News&Howtos  ›  Database  › 

Resolve ORA-28000: the account is locked

Shulou Source: shulou.com Published: 2022-06-01 16:18:12 10月01日 Update

In oracle, if ten consecutive attempts to log in are unsuccessful, the account will be lock. When logging in with a locked account, the system reports an error: ORA-28000: the account is locked.

Query the default value of the FAILED_LOGIN_ATTEMPTS parameter, which limits the number of consecutive login failures from the first login failure.

Sqlplus / nolog

Conn / as sysdba

Desc dba_profiles

Select resource_name,limit from dba_profiles where resource_name='FAILED_LOGIN_ATTEMPTS'

As can be seen from the query results, if the query fails N times in a row, the user will be locked.

one

Log in using a system or sys account, please log in as an administrator.

Enter sqlplus / nolog

Conn / as sysdba

two

Use the command to unlock the user. The command is: alter user username account unlock;, where username is the locked user name.

three

Reset the user password. The command is: alter user username identified by password;, where username is the user name and password is the new password.

four

Try to log in again using your account. If all the commands are executed successfully, you should be able to log in to the system normally.

five

Modify the parameter failed_login_attempts=unlimited, which, of course, reduces security, which is not recommended. Alter profile default limit failed_login_attempts unlimited

Tags: User command account login login parameter success user name system attempt query security password suggestion number of times first time administrator result identity Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Huawei vpn Apple Linux Shulou Information