Get the App
SLTechnology News&Howtos  ›  Internet Technology  › 

How to start the tomcat agent to throw an exception java.rmi.server.ExportException: Port already in use: 1099

Shulou Source: shulou.com Published: 2022-05-31 11:07:54 10月04日 Update

This article mainly explains "start tomcat agent to throw exception java.rmi.server.ExportException: Port already in use: 1099 how to solve", the content of the article is simple and clear, easy to learn and understand, now please follow the editor's train of thought slowly in depth, together to study and learn "start tomcat agent to throw exception java.rmi.server.ExportException: Port already in use: 1099 how to solve" it!

one。 Problem description

The error shown in the following figure occurs when starting the tomcat server in intellij idea:

Error: agent throws exception error: java.rmi.server.exportexception: port already in use: 1099; nested exception is: java.net.bindexception: address already in use: jvm_bind

What is said here is that port 1099 is occupied by other processes.

two。 Solution.

Find out which processes occupy port 1099, enter the windows command, and see what processes occupy port 1099

Use the command: netstat-aon | findstr 1099 to identify the processes occupying port 1099, as shown in the following figure:

Then shut down the process occupying the port: taskkill-f-pid 3756

In this way, you can start tomcat normally. The problem was solved smoothly.

The following is the error report of tomcat startup under linux encountered by the editor: a problem of portalreadyinuse, to share with you the solution.

There are many reasons for the problem, and the title does not explain the specific problem.

Here I only talk about my operation, the problems encountered and their solutions, hoping to play a role in attracting jade.

Start tomcat with the following error:

Error: exception thrown by the agent: java.rmi.server.exportexception: port already in use: 7800; nested exception is:

Java.net.bindexception: address already in use

The configuration files such as ${tomcat_home} / conf/server.xml,context.xml,web.xml were checked and no configuration of port 7800 was found.

So google search, an article gave me a hint:

So the answer is found in the ${tomcat_home} / bin/catalina.sh startup file.

Java_opts= "- server-xms2048m-xmx2048m-xx:permsize=512m-xx:maxpermsize=512m-dcom.sun.management.jmxremote-dcom.sun.management.jmxremote.pwd.file=/opt/app/appcode/jmxremote.password-dcom.sun.management.jmxremote.ssl=false-dcom.sun.management.jmxremote.authenticate=false-dcom.sun.management.jmxremote.port=7803"

Thank you for your reading, the above is the content of "starting tomcat agent to throw exception java.rmi.server.ExportException: Port already in use: 1099 how to solve". After the study of this article, I believe you have a deeper understanding of how to start tomcat agent to throw exception java.rmi.server.ExportException: Port already in use: 1099 to solve this problem, and the specific use needs to be verified in practice. Here is, the editor will push for you more related knowledge points of the article, welcome to follow!

Tags: Problem port agent process error learning content method command file article configuration function reason place that is train of thought situation article Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno OPPO Reno Huawei Linux Apple NVidia