Get the App
SLTechnology News&Howtos  ›  Database  › 

How to solve the problem that SQL Server can't start?

Shulou Source: shulou.com Published: 2022-05-31 18:58:26 10月02日 Update

This article will explain in detail how to solve the problem that SQL Server cannot be started, and the content of the article is of high quality, so the editor will share it for you as a reference. I hope you will have a certain understanding of the relevant knowledge after reading this article.

SQLServer sometimes fails to start correctly because the Executive service cannot log in. One of the main reasons is that LocalSystemAccount and AdministratorGroup do not have complete control over both registry keys.

1) Open the start menu and choose run. Click the Browse button to start browsing until you find the root directory of Windows2000 (usually WINNT). Enter the System directory and locate Regedt32.exe, select it into the dialog box, and click the OK button. Registry Editor starts to display all the configuration units in different cascading sub-windows.

2) Select the "window" menu item HKEY_LOCAL_MACHINE, and its child window is displayed. Maximize the window for ease of use.

3) use the tree control of the left window to navigate to the SOFTWARE\ Microsoft\ MSSQLServer\ SQLExecutive subkey. Click the subitem to select it and display its value in the right window. Navigate to the SYSTEM\ CurrentControlSet\ Services\ SQLExecutive subkey. Click the subitem to select it and display its value in the right window. Ensure that LocalSystemAccount and AdministratorGroup have full control over the item and its children. Repeat the above check for the SYSTEM\ CurrentControlSet\ Services\ MSSQLServer\ SQLExecutive subkey. There are several levels of task failures in SQLServer, including partial task execution failures and all task execution failures. In the latter case, a frequent problem occurs when the registry entry conflicts with the use of named pipes.

Navigate to the SOFTWARE\ Microsoft\ MSSQLServer\ SQLExecutive subkey. Click the subitem to select it and display its value in the right window. Navigate to the entry with the value ServerHost. Use the string editor to change its value so that it does not include the server name (only the named pipe you want to use).

About SQL Server can not start how to solve the sharing here, I hope the above content can be of some help to you, can learn more knowledge. If you think the article is good, you can share it for more people to see.

Tags: Subkeys positioning tasks registry names content buttons articles more entries knowledge pipes articles editors menus controls services browsing selections different Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno macOS Apple Shulou Information OPPO Reno Shulou Technology