Get the App
SLTechnology News&Howtos  ›  Database  › 

TNS-12542: TNS:address already in use

Shulou Source: shulou.com Published: 2022-06-01 18:19:27 09月30日 Update

The research and development said that the database could not be accessed and the database was running normally, so there may be something wrong with the monitoring.

A wave of simple operations is done.

[oracle@entegor-1] $lsnrctl startLSNRCTL for Linux: Version 11.2.0.4.0-Production on 17-AUG-2018 09:04:01Copyright (c) 1991, 2013, Oracle. All rights reserved.Starting / oracle/app/oracle/11.2.0/db_1/bin/tnslsnr: please wait...TNSLSNR for Linux: Version 11.2.0.4.0-ProductionLog messages written to / oracle/app/oracle/diag/tnslsnr/entegor-1/listener/alert/log.xmlError listening on: (ADDRESS= (PROTOCOL=tcp) (HOST=) (PORT=1521)) TNS-12542: TNS:address already in use TNS-12560: TNS:protocol adapter error TNS-00512: Address already in use Linux Error: 98: Address already in useListener failed to start. See the error message (s) above. [root @ entegor-1 ~] # su-grid [grid @ entegor-1 ~] $lsnrctl statusLSNRCTL for Linux: Version 11.2.0.4.0-Production on 17-AUG-2018 09:03:32Copyright (c) 1991, 2013, Oracle. All rights reserved.Connecting to (DESCRIPTION= (ADDRESS= (PROTOCOL=IPC) (KEY=LISTENER)) STATUS of the LISTENER----Alias LISTENERVersion TNSLSNR for Linux: Version 11.2.0.4.0-ProductionStart Date 31-JAN-2018 11:17:57Uptime 197 days 21 hr. 45 min. 34 secTrace Level offSecurity ON: Local OS AuthenticationSNMP OFFListener Parameter File / oracle/app/11.2.0/grid/network/admin/listener.oraListener Log File / oracle/app/grid/diag/tnslsnr/entegor-1/listener/alert/log.xmlListening Endpoints Summary... (DESCRIPTION= (ADDRESS= (PROTOCOL=ipc) (KEY=LISTENER)) (DESCRIPTION= (ADDRESS= (PROTOCOL=tcp) (HOST=6.1.14.125) (PORT=1521)) Services Summary...Service "+ ASM" has 1 instance (s). Instance "+ ASM1", status READY, has 1 handler (s) for this service...The command completed fullness [grid @ entegor-1] $lsnrctl stopLSNRCTL for Linux: Version 11.2.0.4.0-Production on 17-AUG-2018 09:04:16Copyright (c) 1991, 2013, Oracle. All rights reserved.Connecting to (DESCRIPTION= (ADDRESS= (PROTOCOL=IPC) (KEY=LISTENER) The command completed fullness [grid @ entegor-1] $exitlogout [root @ entegor-1] # su-oracle @ entegor-1 ~] $lsnrctl startLSNRCTL for Linux: Version 11.2.0.4.0-Production on 17-AUG-2018 09:04:25Copyright (c) 1991, 2013, Oracle. All rights reserved.Starting / oracle/app/oracle/11.2.0/db_1/bin/tnslsnr: please wait...TNSLSNR for Linux: Version 11.2.0.4.0-ProductionLog messages written to / oracle/app/oracle/diag/tnslsnr/entegor-1/listener/alert/log.xmlListening on: (DESCRIPTION= (ADDRESS= (PROTOCOL=tcp) (HOST=entegor-1) (PORT=1521)) Connecting to (ADDRESS= (PROTOCOL=tcp) (HOST=) (PORT=1521)) STATUS of the LISTENER- -Alias LISTENERVersion TNSLSNR for Linux: Version 11.2.0.4.0-ProductionStart Date 17-AUG-2018 09:04:25Uptime 0 days 0 hr. 0 min. 1 secTrace Level offSecurity ON: Local OS AuthenticationSNMP OFFListener Log File / oracle/app/oracle/diag/tnslsnr/entegor-1/listener/alert/log.xmlListening Endpoints Summary... (DESCRIPTION= (ADDRESS= (PROTOCOL=tcp) (HOST=entegor-1) (PORT=1521) The listener supports no servicesThe command completed fulfilling [oracle @ entegor-1] $lsnrctl statusLSNRCTL for Linux: Version 11.2.0.4.0-Production on 17-AUG-2018 09:14:12Copyright (c) 1991, 2013, Oracle. All rights reserved.Connecting to (ADDRESS= (PROTOCOL=tcp) (HOST=) (PORT=1521)) STATUS of the LISTENER----Alias LISTENERVersion TNSLSNR for Linux: Version 11.2.0.4.0-ProductionStart Date 17-AUG-2018 09:04:25Uptime 0 days 0 hr. 9 min. 46 secTrace Level offSecurity ON: Local OS AuthenticationSNMP OFFListener Log File / oracle/app/oracle/diag/tnslsnr/entegor-1/listener/alert/log.xmlListening Endpoints Summary... (DESCRIPTION= (ADDRESS= (PROTOCOL=tcp) (HOST=entegor-1) (PORT=1521)) Services Summary...Service "+ ASM" has 1 instance (s). Instance "+ ASM1", status READY, has 1 handler (s) for this service...Service "entegor" has 1 instance (s). Instance "entegor1", status READY, has 2 handler (s) for this service...Service "entegorXDB" has 1 instance (s). Instance "entegor1", status READY, has 1 handler (s) for this service...The command completed fulfilling [oracle @ entegor-1 ~] $

Tags: Data database problem wave monitor run Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Microsoft Xiaomi Shulou Technology Shulou Tech Info macOS