Max_connect_errors Settin
Number of max_connect_errors error connections
Default max_connect_errors = 10
If the error connection exceeds max_connect_errors, an error will be reported by mysql
MySql Host is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts'
I personally understand it as a protective mechanism of mysql to prevent ip attacks.
Reason:
Blocking caused by too many database connections interrupted by the same ip in a short period of time (exceeding the maximum of mysql database max_connection_errors)
Solution:
1. Increase the number of max_connection_errors allowed (address the symptoms but not the root of the problem):
The number of modified max_connection_errors is 1000: set global max_connect_errors = 1000
Check whether the modification is successful: show variables like'% max_connection_errors%'
two。 Direct flush hosts