Get the App
SLTechnology News&Howtos  ›  Internet Technology  › 

How to parse the query and monitoring status check alarm in Impala

Shulou Source: shulou.com Published: 2022-06-01 15:43:25 10月02日 Update

This article is about how to parse the Impala query monitoring status check alarm analysis, the editor feels very practical, so share with you to learn, I hope you can learn something after reading this article, say no more, follow the editor to have a look.

In the process of using impala, when you can often see IMPALA on the CM page, you often see the following alarm on IMPALA DAEMON

The health test result for IMPALAD_QUERY_MONITORING_STATUS has become bad: There are 1 error (s) seen monitoring executing queries, and 0 errors (s) seen monitoring completed queries for this role in the previous 5 minute (s). Critical threshold: any.

The following is mainly about the cause of the alarm.

Alarm reappearance and explanation

First of all, we need to know the cause of this alarm. Usually, the alarm appears on a cluster where the impala service is busy. CM will try to link to port impala 25000 to see if the web page is available. The timeout for checking is 5 seconds by default, and the default number of errors is once. The inspection time is every 5 minutes. The timeout of 5 seconds will be shorter for busy clusters, so this problem will be reported. Based on this understanding, due to the limited space in the test cluster, the problem is repeated here through the kill 25000 port process.

After finding the port through lsof-iDrex 25000 and kill to reproduce the problem, if your browser's preferred language is Chinese alarm as shown below:

The relevant parameters are as follows:

Search for Query Monitoring Timeout in impala English interface

Or impala Chinese interface search query monitoring timeout

This parameter is the timeout of the check

Search for impala_query_monitoring_failure_window in impala configuration

The unexpected exit monitoring cycle defaults to 5 minutes.

The unexpected exit threshold defaults to serious alarm at any value.

Modify the parameters as shown below:

After re-verification, it is as follows:

The impala 25000 port process of the kill will be automatically pulled and resumed. Here, there will be an alarm that the 5 daemon exits unexpectedly. For the 25000 port timeout alarm, due to the modification of the threshold, a yellow warning query appears.

The above alarm appears in the monitoring status check, which does not mean that the impala deamon service of the node is unavailable. In most cases, it is caused by the port busy access timeout.

The above is how to parse the query monitoring status check alarm in Impala. The editor believes that there are some knowledge points that we may see or use in our daily work. I hope you can learn more from this article. For more details, please follow the industry information channel.

Tags: Check port monitor query time status accident parameter process problem cluster search reason more interface knowledge article Chinese service practical Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Microsoft Shulou Information Shulou Technology Shulou Tech Info Docker