How to solve the problem of Not yet valid when installing SSL certificate in Citrix NetScaler
If there is an error prompt for Not yet valid when Install certification in Citrix NetScaler, as shown in the following figure
Such a prompt is usually caused by a mismatch between the time zone or time and the time of CA. The time difference is controlled within 3 minutes, preferably synchronized.
If the NetScaler at this time is configured in the hardware in MDX, log in to the NS command line with ssh, shell, set the time with date 1435 14:35 in the afternoon or enable NTP synchronization
If you are deploying in NetScaler VPX, check whether your Hypervisor time is correct. Many times are caused by incorrect Hypervisor time. After changing the time, restart the VPX virtual machine. You can generally install CA and Valid.