Get the App
SLTechnology News&Howtos  ›  Internet Technology  › 

Stability problem case-Error-27796: Failed to connect to server

Shulou Source: shulou.com Published: 2022-06-03 06:42:32 10月03日 Update

Phenomenon: during the two-night stability test, it was found that the response dropped to the trough and lasted for a period of time, and then the response tended to be stable, and the time periods of the two nights were inconsistent. There was nothing unusual in checking the corresponding log, and an error was reported in the loadrunner monitor.

Action.c (4): Error-27796: Failed to connect to server: Failed to connect to server "stadig.ifeng.com:80": [10048] Address already in use Try changing the registry value

HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/tcpip/Parameters/TcpTimedWaitDelay to 30 and HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/tcpip/Parameters/MaxUserPort to 65534

Guess the reason: the performance of the client is better, and the pressure is too fast, so the connection or port of tcp/ip is full. After looking it up on the Internet, xp seems to have 15 tcp/ip enabled by default. And the default value of TcpTimedWaitDelay is 4 minutes.

Solution: change the corresponding value according to the above prompts, and the problem does not appear again for another night, and the overall response is very smooth. However, the above errors will continue to be reported in loadrunner, but it will have no effect on the response.

Tags: Smooth nothing time stability problem consistency pressure cause just customer client performance whole time period phenomenon monitor port trough process face Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Linux Docker Shulou Information Redmi OPPO Reno