The method of starting slave error repair after mysql Database Migration Directory
This article mainly introduces the mysql database migration directory to start slave error repair methods, the contents of the article are carefully selected and edited by the author, with a certain pertinence, for everyone's reference significance is still relatively great, the following with the author to understand the mysql database migration directory after starting slave error repair method.
When using the source / sql file to import the database, the file is too large, resulting in a timeout.
Later, use scp-r to copy the entire directory and start slave to report an error. Then I wrote a script to fix it in batches:
#! / bin/sh
/ usr/local/mysql/bin/myisamchk-of. / sundiszuzx/$1
/ usr/local/mysql/bin/myisamchk-r. / sundiszuzx/$1
/ usr/local/mysql/bin/myisamchk-- safe-recover. / sundiszuzx/$1
After reading the above about the mysql database migration directory, start the slave error repair method, many readers must have some understanding, if you need to get more industry knowledge and information, you can continue to follow our industry information column.