Get the App
SLTechnology News&Howtos  ›  Database  › 

The solution to the failure of login caused by the Oracle user password containing special characters

Shulou Source: shulou.com Published: 2022-06-01 15:27:31 10月04日 Update

My system/sys user's password contains an @ character. For example, if my password is 123cm 456, it will be understood as sqlplus system/123@456@webdata when logging in using sqlplus, so sqlplus will be understood as the connection string of the database followed by 123.This will naturally report an error and prompt TNS that the specified connection identifier or no listener cannot be parsed

Then change the sys/system password after logging in with sqlplus / as sysdba on the server, and everything will be fine if you try again.

When the password of an Oracle database user contains a special character such as @, the normal password is entered directly. The login fails because oracle parses the @ character to the network service name.

The user name shown below is: wang password: oracle@1 network service name: sun:

Linux platform: 'wang/ "oracle@1' @ sun-1 double quotation mark extension password, 1 single quotation mark extension user name + password, that is, 'user name / password' @ service name

[11:41:14oracle@dvd adump] $sqlplus wang/oracle@1@sun

SQL*Plus: Release 11.2.0.1.0 Production on Tue Oct 30 11:41:24 2012

Copyright (c) 1982, 2009, Oracle. All rights reserved.

ERROR:

ORA-12532: TNS:invalid argument

[11:42:24oracle@dvd adump] $sqlplus' wang/ "oracle@1" @ sun-1 double quotation mark extension password, 1 single quotation mark extension user name + password, that is, 'user name / password' @ service name

SQL*Plus: Release 11.2.0.1.0 Production on Tue Oct 30 11:42:25 2012

Copyright (c) 1982, 2009, Oracle. All rights reserved.

Connected to:

Oracle Database 11g Enterprise Edition Release 11.2.0.1.0-Production

With the OLAP and Data Mining options

Wang@SUN >

Windows platform: wang/ "oracle@1"@ sun--3 double quotation mark extension password, that is, user name /" password "" @ service name

C:\ Users\ wanglei.ITADMIN > sqlplus wang/oracle@1@sun

SQL*Plus: Release 11.2.0.1.0 Production on Tuesday October 30 13:20:00 2012

Copyright (c) 1982, 2010, Oracle. All rights reserved.

ERROR:

ORA-12154: TNS: unable to parse the specified connection identifier

Please enter a user name:

C:\ Users\ wanglei.ITADMIN > sqlplus wang/ "" oracle@1 "" @ sun--3 double quotation mark extension password, that is, username / "" password "" @ service name

SQL*Plus: Release 11.2.0.1.0 Production on Tuesday October 30 13:20:30 2012

Copyright (c) 1982, 2010, Oracle. All rights reserved.

Connect to:

Oracle Database 11g Enterprise Edition Release 11.2.0.1.0-Production

With the OLAP and Data Mining options

Tags: Password user name service quotation mark character platform data database week identity identifier network network service login input special login again string Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno vpn Apple macOS Shulou Information Docker