Get the App
SLTechnology News&Howtos  ›  Database  › 

The solution to the error of reporting 2059 in navicat connection MySQL

Shulou Source: shulou.com Published: 2022-06-01 01:15:29 10月06日 Update

This article will explain in detail the solution to the error of navicat connecting MySQL newspaper 2059. The editor thinks it is very practical, so I share it with you for reference. I hope you can get something after reading this article.

A 2059 error occurs when connecting to MySQL8+ with navicat, because the new version of MySQL uses caching_sha2_password authentication, which is not supported by navicat at this time.

The solution is to change the authentication method to the authentication method mysql_native_password used in previous versions (5.7 and below).

You can check the plugin field of the user table in the default database 'mysql' for specific verification methods.

There is no 2059 error when logging in to the database on the command line. Log in to the database on the command line and execute the following command.

ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY' password'

"root' can be changed to your own defined user name," localhost' refers to the user's open IP, can be "localhost'" (native access only, equivalent to 127.0.0.1), can be specific '... " (specific IP), or'%'(all IP can be accessed). Password' is the authentication password you want to use.

Friendly tip: be sure to keep in mind the changed password, otherwise it will be troublesome to forget.

On the navicat connection MySQL report 2059 error solution is shared here, I hope the above content can be of some help to you, can learn more knowledge. If you think the article is good, you can share it for more people to see.

Tags: Authentication method error method command data database password more user article login good practical content friendship field that is article version Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Linux Docker Huawei Xiaomi MariaDB