What if the SQLServer2008 database is marked as suspicious
This article will explain in detail what to do when the SQLServer2008 database is marked as suspicious. The editor thinks it is very practical, so I share it for you as a reference. I hope you can get something after reading this article.
When this operation failure occurs in the database, you can follow the following steps to solve this method. Open the Sql query editor window in the database and run the following command.
1. Modify the database to emergency mode
ALTERDATABASEZhangxingSETEMERGENCY
2. Change the database into single-user mode
ALTERDATABASEZhangxingSETSINGLE_USER
3, repair database log regeneration, this command checks the allocation, structure, logical integrity and object errors in all databases. When you specify "REPAIR_ALLOW_DATA_LOSS" as the DBCCCHECKDB command parameter, the program checks for and fixes reported errors. However, these fixes may result in some data loss.
DBCCCheckDB (Zhangxing,REPAIR_ALLOW_DATA_LOSS)
4. Change the database back to multi-user mode
ALTERDATABASEZhangxingSETMULTI_USER
What are the solutions to which the SQLServer2008 database is marked as suspicious
You can also do this:
1: re-create the same database, path name, and file.
2: turn off the SQLServer service
3: bring the source file COPY
4: open the SQLServer service, and the problem will also be solved.
This is the end of the article on "what to do if the SQLServer2008 database is marked suspicious". I hope the above content can be of some help to you, so that you can learn more knowledge. if you think the article is good, please share it for more people to see.