Get the App
SLTechnology News&Howtos  ›  Servers  › 

The solution to the error of phpcms Publishing articles

Shulou Source: shulou.com Published: 2022-06-02 05:51:45 10月01日 Update

This article will explain in detail the solutions to errors in phpcms publishing articles. The editor thinks it is very practical, so I share it for you as a reference. I hope you can get something after reading this article.

What if there is an error in the phpcms publishing article? Phpcms returned 500 errors when logging in to the website to publish articles in the background.

Webmasters who often use the CMS system to build websites must be familiar with phpcms, this open source program is built by php+mysql, this CMS system is suitable for shopping malls, film and television, platform information sites to build the most perfect, at the same time, with continuous improvement, this program is also very popular on the Internet a lot of open source templates.

With the system plus template, it is much faster to use this program to build a website. With the upgrade of the PHPCMS system, there have been some bug recently. Today, the editor helped a friend of the webmaster move. The webmaster is an information platform built by PHPCMS.

When the move is ready, the webmaster failed to log on to the backstage of the website to publish the article, prompting that a 500 error was returned, and then immediately jumped back to the previous position.

The editor looked up a lot of data but summed up the two most likely causes. The following editor analyzes and studies how to solve the problem according to two possible reasons.

The first kind:

It may be that the server or a function of the server is not enabled. If you are using the CVM with its own environment, then fsockopen () may be disabled, and you need to call the configuration file html.class.php lib to enable it. Sometimes the CVM used may also be installed by some antivirus software to kill some files of phpcms by mistake, resulting in incomplete files. Similar problems can occur.

The second kind:

This is the bug of the program itself. Due to the constant upgrading of phpcms. In this way, bug was born one after another. The most common is caused by a change in the way phpcms is stored in session.

First, we find the path / caches/configs/system.php of the following files.

Just connect to ftp and change the mysql in 'session_storage' = >' mysql' to files.

Put the following code code:

'session_storage' = >' mysql' is stored by database

Modified to:

'session_storage' = >' files' is stored as a file

After modification, upload to the corresponding directory to overwrite. Then log in to the background of the website and update the cache with one click. When you click to edit the article again, it will be released normally.

This is the end of the solution to the mistakes in phpcms publishing articles. I hope the above content can be helpful to you and learn more knowledge. If you think the article is good, you can share it for more people to see.

Tags: Article file website program webmaster system background time storage login method continuous two host code information reason platform more server Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno macOS vpn MySQL Docker OPPO Reno