Centos mounts the windows domain control shared directory
an environment
SERVER:windows server 2012 R2 DC Domain IP: 192.168.1.11
CLIENT:Centos 6.5
Two mounts
Command:
mount -t cifs -o username='test\testuser',password='test' "//192.168.1.11/server test/test" /mnt/testmount: block device //192.168.1.11/server test/test is write-protected, mounting read-onlymount: cannot mount block device //192.168.1.11/server test/test read-only
Error:write-protected, mounting read-only
Need to install:
yum install cifs-utils.x86_64
After the installation is complete, you can continue to execute.
Three boot auto mount
After the mount is completed, it will fail after shutdown. You can modify the/etc/fstab file to implement the boot mount by adding a line:
"//192.168.1.11/server test/test" /mnt/test cifs auto,username='test\testuser',password='test' 0 0
4 Other
-t cifs(common internet file system) Specifies the file type
-o Specifies options for mounting files ro read-only rw read-write
username and password are the login username and password. In domain environment, the username needs to be added with domain name.
Shared directory address, double quotes "" if directory name has spaces
Shared directories for linux mounted domain servers require that the user account has read and write permissions to shared files.
Five reference links
http://blog.chinaunix.net/uid-8810763-id-2453890.html mount command detailed explanation
http://blog.csdn.net/jingxia2008/article/details/50218933 mount failed password hash problem
http://blog.csdn.net/lanyou1900/article/details/39612585 boot automatic mount