Several problems and Solutions in installing Exchange 2013 CU18
Exchange 2013 and Exchange 2016 released updated versions of Exchange Server 2013 CU18 and Exchange Server 2016 CU17 respectively on September 16, 2017. The download addresses are:
Exchange 2013 cu18
Https://www.microsoft.com/en-us/download/details.aspx?id=55955
Exchange Server 2016 CU7
Https://www.microsoft.com/en-us/download/details.aspx?id=55953
Front-end time encountered three problems in the process of updating Exchange 2013 cu17 To cu18, and I tried to solve all these problems. I will share the problem-solving process below.
Problem 1: during the installation of Exchange 2013 CU18, gist "the file exchangeserver.msi does not exist in the specified directory C:\ Program Files\ Microsoft\ Exchange Server\ V15\ bin"
Screenshot of error phenomenon:
Solution: after manually extracting the Exchange Server 2013 CU17 patch, copy the exchangeserver.msi file to the C:\ Program Files\ Microsoft\ Exchange Server\ V15\ bin directory and re-perform the Exchange server cu18 installation. (currently C:\ Program Files\ Microsoft\ Exchange Server\ V15\ bin is determined based on the actual path where Exchange is installed. )
Question 2: "cannot fail ManageScheduledTask.ps1 entry to the name of cmdlet, function, script file, or runnable program"
Workaround: run Powershell as an administrator and then execute the command.\ Setup / mode:upgrade / IAcceptExchangeServerLicenseTerms to install the Exchange CU18 program. (I used an unattended installation in command mode for this error, which might not have occurred if I used UI installation. )
Question 3: "during the installation process, when it comes to the" restore service "phase, it is prompted that some of the Exchange services cannot be started successfully.
Solution: during the installation of Exchange server 2013 cu18, the installer will first set the related services of Exchange to be disabled, and then set to start automatically or automatically delay startup after the installation is complete. However, during the installation of Exchange 2013 CU18, it occurred that the startup mode of the service could not be set to automatic or automatic delayed startup during the installation of Exchange 2013 CU18, so I manually used the command Get-Service-name msexch* | Set-Service-StartupType Automatic to set the startup type of Exchange-related services to automatic startup when installing Exchange to restore service phase. After setting up in this way, the installer installs successfully.