Get the App
SLTechnology News&Howtos  ›  Servers  › 

How to solve the problem caused by the large body of nginx upload request?

Shulou Source: shulou.com Published: 2022-05-31 16:48:27 09月21日 Update

This article mainly explains "how to solve the problem caused by too big nginx upload request". The content in the article is simple and clear, and it is easy to learn and understand. Please follow the editor's train of thought to study and learn how to solve the problem caused by too big nginx upload request.

1. Reason

GitLab error: RPC failed; result=22, HTTP code = 413

The upload request body is too large, which leads to

two。 Solution.

A. add client_max_body_size parameters to nginx configuration file, such as client_max_body_size 50m

B. Vi / etc/nginx/sites-enabled/gitlab modify client_max_body_size 50m

C.vi / home/git/gitlab/config/gitlab.yml modify max_size: 20971520 # 20.megabytes

D.vi / home/git/gitlab/app/models/note.rb modifies validates: attachment, file_size: {maximum: 500.megabytes.to_i}

e. Restart nginx restart gitlab (/ etc/init.d/gitlab restart)

Thank you for your reading, the above is the content of "how to solve the problem caused by too large body of nginx upload request". After the study of this article, I believe you have a deeper understanding of how to solve this problem caused by the large body of nginx upload request, and the specific use needs to be verified in practice. Here is, the editor will push for you more related knowledge points of the article, welcome to follow!

Tags: Question study content method reason parameter that is train of thought situation document article more knowledge knowledge point article follow a.meme. Zhongxin practice Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno vpn Shulou Tech Info macOS Linux Shulou Technology