Get the App
SLTechnology News&Howtos  ›  Servers  › 

A successful case of forced online after the server hard disk is offline

Shulou Source: shulou.com Published: 2022-06-03 09:44:48 10月02日 Update

Everyone should be familiar with the server. We don't explain the concept of the server too much. Let's go straight to the topic: if other hard drives fail and interrupt the synchronization process during the process of synchronizing data after the hard disk is replaced by the server, what should be done at this time to restore the data in the original server? The following describes the method of forcing the server hard disk to go online after it is offline.

There is a prerequisite to introduce, that is, my server data recovery tutorial today is applicable to raid5 disk arrays, on the one hand, because the security factor of raid5 array is higher than other arrays, most enterprises configure riad5 array mode for servers, another reason is that raid5 array server data recovery is relatively easy, the professional requirements of data recovery technology is not high, strong operability. The following through a real case to introduce the server in the replacement of hard disk synchronization process of other hard disk offline data recovery method.

[server data recovery failure description]

This is a large server with more than 40 hard drives installed in raid5 disk array mode. The process of failure is that the failure of data synchronization is caused by the loss of the hard disk in the process of array synchronization. The integrity of this data recovery is 100%.

[backup before server data recovery]

The original data of the failed server that needs to be operated should be backed up before data recovery (whether server administrator or professional data recovery company). Then since there is a hard disk in the server that is offline, it should be physically damaged. In this way, the offline hard disk should be checked in the process of backup. If there is a bad way to use some tools (troubleshooting 3000 is recommended). These mirroring tools can skip bad sectors for mirroring. If it is found that it is a magnetic head fault, disk fault, then it is not recommended to rush to open the market. In this data recovery case, we take the physical bad path as an example.

[force online to recover server data]

There are two kinds of data recovery methods commonly used when there are multiple hard drives offline in the server. the first is the forced online operation, of course, there is a certain lucky element in this operation, and only a small number of them can succeed. When most servers fail to go online, they can only allow professional data recovery companies to reorganize and restore the server array, which is not needed in this case.

Before the server hard disk is forced to go online, the administrator is required to know the sequence in which each hard disk of his server goes offline and removes the disconnected hard disk first, and the last offline hard disk image and other disks are reonline together. Data recovery to this step if successful, all data will be successfully restored, if online failure can only take the second way of data recovery.

[server data recovery Tips]

When using the server, many customers think that the safety factor of the raid5 array mode is very high, and they are more comfortable with the raid5 array, so they will not set up a backup mechanism for the server. Of course, with the improvement of the security performance of the current server, combined with the security mechanism of the array, many servers have never lost data during their service. However, we still recommend that customers establish a backup mechanism for their servers to avoid 1/10000 data loss. Avoid economic losses.

Tags: Server service data hard disk data recovery array failure process compulsion backup synchronization security that is success professionalism mechanism mode mirror case safety factor Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Redmi Shulou Tech Info vpn Linux Docker