Prompt the certificate name error after Outlook login
-provide Microsoft product implementation and outsourcing, such as AD\ Exchange\ Lync\ Sharepoint\ CRM\ SC\ O365, QQ:185426445. Tel. 18666943750
Server environment: Exchange server 2007 SP3
Client: WIN7+Outlook2010
Connection method: Anywhere
Certificate: a third-party public network certificate is used to issue the certificate. The name of the certificate is mail.contoso.com, and the alternate name of the subject is mail.contoso.com,autodiscover.contoso.com (this is the name of the certificate used in the test environment, which is similar to the real environment).
Problem: after opening Outlook, it prompts you that the certificate name is incorrect and displays the Exchange2007 internal host name exchange2007.
After investigation, the server uses the public network certificate issued by a third-party certificate authority, not including the internal name of the computer.
1. Set the relevant virtual directories to the external domain name mail.contoso.com.
Add-PSSnapin microsoft.exchange*
Get-OwaVirtualDirectory | fl name,InternalUrl,ExternalUrl
Get-ActiveSyncVirtualDirectory | fl name,InternalUrl,ExternalUrl
Get-OabVirtualDirectory | fl name,InternalUrl,ExternalUrl
Get-WebServicesVirtualDirectory | fl name,InternalUrl,ExternalUrl
Get-OwaVirtualDirectory | Set-OwaVirtualDirectory-ExternalUrl https://mail.contoso.com/owa-InternalUrl
Https://mail.contoso.com/owa
Get-ActiveSyncVirtualDirectory | Set-ActiveSyncVirtualDirectory-ExternalUrl
Https://mail.contoso.com/Microsoft-Server-ActiveSync-InternalUrl https://mail.contoso.com/Microsoft-Server-ActiveSync
Get-OabVirtualDirectory | Set-OabVirtualDirectory-ExternalUrl https://mail.contoso.com/OAB
Get-WebServicesVirtualDirectory | Set-WebServicesVirtualDirectory-InternalUrl
Https://mail.contoso.com/EWS/Exchange.asmx-ExternalUrl https://mail.contoso.com/EWS/Exchange.asmx
Get-OutlookAnywhere
Get-ClientAccessServer | select name,auto*
Get-ClientAccessServer | Set-ClientAccessServer-AutoDiscoverServiceInternalUri
Https://autodiscover.contoso.com/Autodiscover/Autodiscover.xml
2. Make sure that the anywhere is also connected with the external name mail.contoso.com.
3. The client still reports a certificate error, which is suspected to be related to TLS authentication, so modify the relevant settings to solve the problem, and the certificate error is not reported when outlook is opened. Cancel the receive connector default as shown below. Basic authentication is provided only after TLS is started.
4. Set up client... The FQDN name of the connection is mail.contoso.com.
5. Cancel the receive connector client. Basic authentication is provided only after TLS is started.