Get the App
SLTechnology News&Howtos  ›  Servers  › 

[Troubleshooting] Hyper-V CLUSTER migration resource error

Shulou Source: shulou.com Published: 2022-06-03 01:53:40 10月04日 Update

When you encountered a problem some time ago, when you tried to migrate the cluster shared volume to another node in the newer 2012 R2 Hyper-V failover cluster, an error message was reported indicating that it was not the node owner:

"error code: the 0x80071398 operation failed because the specified cluster node is not the owner of the group, or the node is not a possible owner of the group"

We use cluster.exe to add my second node as a possible owner of CSV, with the following syntax:

Cluster resource "csv_AL" / listowners

When we tried that it could not be executed with the cluster.exe command, it turned out to be unrunnable.

Error running cluster.exe in Server 2012 R2

About installing failover clustering features and tools in Windows Server 2012

In the blog post, it indicates that you can install the Windows feature RSAT-Clustering-CmdInterface, including "unavailable cluster.exe command-line tools for failover clustering."

I have installed the failover clustering module for Windows PowerShell, and I can't figure out how to make the second node the possible owner of CSV, so I installed RSAT-Clustering-CmdInterface to use the cluster.exe command

Install RSAT-Clustering-CmdInterface to use cluster.exe

After the installation is complete, I can use cluster.exe to add my second node as the possible owner of "VM csv_a1". Then add the available node, and finally restart it.

Tags: Nodes owners failures commands attempts functions tools errors runs code including blogs articles time to make modules messages syntax problems Zhongan Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno MySQL macOS Shulou Information OPPO Reno Linux