Get the App
SLTechnology News&Howtos  ›  Servers  › 

Create database copy exception

Shulou Source: shulou.com Published: 2022-06-02 21:16:29 09月22日 Update

Environment: direct loading of mail database on server A (mail02) prompts you to report an error, and you need to manually load the database successfully. DAG also encountered an error in creating a copy in B (MAIL04).

Summary: 1 project. 0 succeeded and 1 failed. Time spent: 00:00:04

A failure

Error: seed setting operation failed. Error an error occurred while performing the seed operation. Error: failed to truncate the context in the log of the open source server 'ASZMAIL02.lgan.net.cn'. Hresult: 0xfffffae7 . Error: database not found or replicated. [database: a, server: ASZMAIL04.lgan.net.cn]

Failed to truncate the context of the log of the open source server 'ASZMAIL02.lgan.net.cn'. Hresult: 0xfffffae7 . Error: database not found or replicated. Click here for help. Http://technet.microsoft.com/zh-CN/library/ms.exch.err.default(EXCHG.140).aspx?v=14.3.361.1&t=exchgf1&e=ms.exch.err.Ex4543D9

The running Exchange Management Shell command: Add-MailboxDatabaseCopy-Identity'a'- MailboxServer 'ASZMAIL04'-ActivationPreference' 2'

Time spent: 00:00:04

New c has been completed

Warning: an error occurred while trying to pre-populate the newly created mailbox "/ o=Lgan Mail Org/ou=Exchange Administrative Group (FYDIBOHF23SPDLT) / cn=Recipients/cn=SystemMailbox {202af1df-a75a-4f03-a4bf-b6f2dc2edbe4}" in database "c" on server "ASZMAIL02". The mailbox "/ o=Lgan Mail Org/ou=Exchange Administrative Group (FYDIBOHF23SPDLT) / cn=Recipients/cn=SystemMailbox {202af1df-a75a-4f03-a4bf-b6f2dc2edbe4}" will not be available for some cmdlets and operations until the user is replicated on the system. If you need to run cmdlet again and want to know more about the error, add the-Verbose parameter. Error: 0x8004010F.

Completed Exchange Management Shell command: new-mailboxdatabase-Server 'ASZMAIL02'-Name' c'-EdbFilePath'e:\ Mailbox\ c\ c.edb'-LogFolderPath'e:\ Mailbox\ c'

Time spent: 00:00:00

Failed to load c

Error: unable to mount the specified database. Specified database: C; error code: activity manager operation failed. The specified mailbox database whose GUID is' 202af1dfmura75amur4f03mura4bfmurb6f2dc2edbe4' was not found. [database: C, server: ASZMAIL02.lgan.net.cn].

The activity Manager operation failed. The specified mailbox database whose GUID is' 202af1dfmura75amur4f03mura4bfmurb6f2dc2edbe4' was not found. [database: C, server: ASZMAIL02.lgan.net.cn]

Exchange Management Shell command that has been run: mount-database-Identity 'c'

Time elapsed: 00:00:00 solution:

Resolution:

The issue can be solved by deleting the DumpsterInfo registry key from both "Source" and "Target" DAG members. To do that, remove the registry key HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/ExchangeServer/v14/Replay/State//DumpsterInfo

To find the database GUID-run

Get-MailboxDatabase DB4 | Fl Name, GUID

Remember that you need to perform this step on both Source and Target nodes or it wont work.

Exchange Server error: "The trust relationship between this workstation and the primary domain failed"

Another way of thinking environment: server B (mail04) to create a mail database directly load the error message, you need to manually load the library successfully. At the same time, the creation of a copy in A (MAIL02) turned out to be successful.

3.Exchange 2010 recommends that database space naming such as Three Staff be prohibited in creating data. The hidden danger is the following errors. Question how to get the GUID number of a database name with spaces through the space

[PS] C:\ Windows\ system32 > Get-MailboxDatabase-identity Three Staff-status | format-list cannot find a positional parameter that accepts the actual parameter "Staff".

+ CategoryInfo: InvalidArgument: (:) [Get-MailboxDatabase], ParameterBindingException+ FullyQualifiedErrorId: PositionalParameterNotFound,Get-MailboxDatabase

Tags: Data database error server service command administration success mailbox load parameter program run copy up and down context at the same time manual log environment Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Shulou Information Xiaomi MySQL NVidia Docker