Get the App
SLTechnology News&Howtos  ›  Servers  › 

How openstack allocates floating IP

Shulou Source: shulou.com Published: 2022-05-31 16:10:36 10月03日 Update

This article mainly introduces how openstack allocates floating IP, which has certain reference value. Interested friends can refer to it. I hope you will gain a lot after reading this article. Let Xiaobian take you to understand it together.

When openstack allocates floating IP, read the first_ip field of the corresponding network from neutron.iavailabilityranges table, allocate the current first_ip as floating IP, and then update the first_ip value plus one. If the IP is actually occupied, the horizon interface reports an error, and the error message is unknown.

If the assigned floating IP is released in Horizon's Access and Security interface, it cannot be reassigned to other items and needs to be manually modified in the first_ip field of the iavailabilityranges table to reassign

update ip availabilityranges set first_ip='10.62.44.82' where allocation_pool_id='1b39516e-6d9e-482b-92fd-d122f642643 a'; Thank you for reading this article carefully, I hope that Xiaobian shared "How to allocate floating IP" This article is helpful to everyone, but also hope that everyone supports more, pay attention to the industry information channel, more relevant knowledge waiting for you to learn!

Tags: Assign float article field interface security value information interest at the same time actual situation manual more friends knowledge ribbon network industry information Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Redmi Huawei macOS Shulou Tech Info Apple