Resolve Wordpress blog installation plug-in error
Problem found:
Websites that use the Wordpress architecture will always prompt us for an interface that requires us to provide FTP information when they need to upgrade or install themes or plug-ins in the background. It says, "to perform the requested operation, WordPress needs access to your web server. Please enter your FTP login credentials to continue."
The error is as follows:
Solution: 1. Modify the configuration file
Cd / usr/share/nginx/html
Vim wp-config.php
Define ("FS_METHOD", "direct"); define ("FS_CHMOD_DIR", 0777); define ("FS_CHMOD_FILE", 0777)
two。 Restart the service
Systemctl restart nginx
3. There is a new problem with web page validation:
Solution: 1. Authorize the creation of directories
Chmod 777-R wp-content/
two。 Web page validation: successfully resolved