Get the App
SLTechnology News&Howtos  ›  Servers  › 

Resolve Wordpress blog installation plug-in error

Shulou Source: shulou.com Published: 2022-06-03 04:49:37 09月21日 Update

Problem found:

Websites that use the Wordpress architecture will always prompt us for an interface that requires us to provide FTP information when they need to upgrade or install themes or plug-ins in the background. It says, "to perform the requested operation, WordPress needs access to your web server. Please enter your FTP login credentials to continue."

The error is as follows:

Solution: 1. Modify the configuration file

Cd / usr/share/nginx/html

Vim wp-config.php

Define ("FS_METHOD", "direct"); define ("FS_CHMOD_DIR", 0777); define ("FS_CHMOD_FILE", 0777)

two。 Restart the service

Systemctl restart nginx

3. There is a new problem with web page validation:

Solution: 1. Authorize the creation of directories

Chmod 777-R wp-content/

two。 Web page validation: successfully resolved

Tags: Web pages problems solutions websites solutions prompts services validation plug-ins success subject information credentials background words files time server permissions architecture Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno MariaDB Shulou Tech Info Redmi vpn MySQL