Windows's Rsync service
1. After the computer is powered off and restarted, the rsync server cannot start by itself. Manually pull the error "prompt" that the RsyncServer service on the local computer starts and then stops, and some services will automatically stop when they are not used by other servers or programs. "
2. The analysis of online bosses.
When the RsyncServer ends abnormally, the pid file is not deleted in time, so that when the service is started again, it is thought to have been started because the pid file is detected to exist, so the startup operation will not be performed. The service manager of windows does not use pid as the detection standard, so the above prompt to start and stop is popped up.
3. The solution
Manually delete the pid file generated by RsyncServer in the installation directory, start it again and solve it.