Cause Analysis of Modification / dev/shm restart failure
Modification / dev/shm restart failure cause analysis, I believe that many inexperienced people do not know what to do, so this paper summarizes the causes of the problem and solutions, through this article I hope you can solve this problem.
General treatment methods:
1. Edit / etc/fstab
# vim / etc/fstab
Before modification: tmpfs / dev/shm tmpfs defaults 0 0
Modified: tmpfs / dev/shm tmpfs defaults,size=32g 0 0
2. Re-mount / dev/shm
# mount-o remount / dev/shm
Under normal circumstances, the above two operations will take effect.
For systems with redhat or centos version 6 or later
The setting becomes invalid after restart. You need to execute mount-o remount / dev/shm after startup to take effect. This problem should be a bug of the system, which can be found (https://bugzilla.redhat.com/show_bug.cgi?id=669700) in redhat's bugzilla. There is also a solution to this problem, as shown below:
Edit / etc/rc.d/rc.sysinit
# vim / etc/rc.d/rc.sysinit
Before modification: mount-f / dev/shm > / dev/null 2 > & 1
Modified: mount / dev/shm > / dev/null 2 > & 1
After reading the above, have you mastered the method of modifying / analyzing the cause of dev/shm restart failure? If you want to learn more skills or want to know more about it, you are welcome to follow the industry information channel, thank you for reading!