What if the virtual machine fails to start after the host restarts in OpenStack?
Editor to share with you OpenStack host restart after the failure to start the virtual machine, I believe that most people do not know much, so share this article for your reference, I hope you will learn a lot after reading this article, let's learn about it!
[problem phenomenon] failed to start the virtual machine after rebooting due to physical machine failure. Check the nova-compute.log log and find:
2016-04-06 13 TRACE oslo_messaging.rpc.dispatcher Command 27 VR 06.206 1346 TRACE oslo_messaging.rpc.dispatcher Command: sudo nova-rootwrap / etc/nova/rootwrap.conf iscsiadm-m node-T iqn.2010-10.org.openstack:volume-bdd8edd6-2358-4398-9ef4-bc15b12573ed-p 172.16.70.2 VR 3260-- rescan
2016-04-06 13 TRACE oslo_messaging.rpc.dispatcher Exit code 2714 06.206 1346
View / var/log/messages log discovery
Iscsid: Connection39:0 to [target: iqn.2010-10.org.openstack:volume-bdd8edd6-2358-4398-9ef4-bc15b12573ed, portal: 172.16.70.2 iface 3260] through [iface: default] is shutdown.
[problem Analysis]
[solution]
There is the relevant configuration of target in the / etc/target/ directory. Analyze the contents of saveconfig.json and the contents of backup, and find that the information of authentication has been lost in saveconfig.json. You can restore the backup configuration to saveconfig.json.
These are all the contents of the article "what to do if the virtual machine fails to start after the host restarts in OpenStack". Thank you for reading! I believe we all have a certain understanding, hope to share the content to help you, if you want to learn more knowledge, welcome to follow the industry information channel!