Ceph-deploy error what to do with UnableToResolveError Unable to resolve host
This article mainly introduces the ceph-deploy error UnableToResolveError Unable to resolve host how to do, has a certain reference value, interested friends can refer to, I hope you can learn a lot after reading this article, the following let the editor take you to understand it.
Background
Ps: in this article, assume that the hostname of my system is node1.
Use the ceph-deploy command to set up a Ceph cluster, and the following error occurs when executing ceph new node1:
[node1] [INFO] Running command: / bin/ip addr show [node1] [DEBUG] IP addresses found: ['192.168.56.16,' 172.17.0.1, '10.0.2.15'] [ceph_deploy.new] [DEBUG] Resolving host Node1 [ceph _ deploy] [ERROR] UnableToResolveError: Unable to resolve host: node1
Before calling this command, ssh password-free login has been set, and both ping and password-free login to node1.
Reason
One of the headache features of Ubuntu is that hostname uses its loopback loopback address in the / etc/hosts configuration file. This feature makes it impossible for many services to detect the real address. Here, in ceph-deploy, ceph_deploy.util.get_nonlocal_ip gets the address of the 127th network segment and then reports an error that it cannot resolve the hostname.
Solution method
In / etc/hosts, delete the hostname corresponding to the loopback address. Then add a line of real ip address and hostname correspondence, and you can.
Thank you for reading this article carefully. I hope the article "what to do with ceph-deploy error UnableToResolveError Unable to resolve host" shared by the editor will be helpful to everyone. At the same time, I also hope that you will support us and pay attention to the industry information channel. More related knowledge is waiting for you to learn!