How to solve the error problem of importing metricbeat into dashboard
Add a metricbeat to ELK stack 6.8.6 for fine-grained monitoring of system,kafka
The configuration file before the error is as follows:
# configuration added on the default basis
/ etc/metricbeat/metricbeat.yml
# = Modules configuration = reload.enabled: true#= Dashboards = setup.dashboards.enabled: truesetup.dashboards.url: "http://IP:5601"#==================== Kibana = = setup.kibana: host:" http://IP:5601"#==================== Ouputs = = output.elasticsearch: hosts: ["ES_IP:9200"]
Restart metricbeat after adding configuration
Restart OK
But cannot load dashboard
There is no journal for this problem, and it has been entangled for a long time, so it can only be reinstalled, and it turns out that
Just unregister the following two lines of configuration
# setup.dashboards.enabled: true#setup.dashboards.url: "http://IP:5601"
After restarting metricboard, import dashboard
# metricbeat setup-dashboard system
If the import is successful, enter kibana again, and you can see the imported dashboard.
You can see the system data after index