Get the App
SLTechnology News&Howtos  ›  Servers  › 

How to solve the error problem of importing metricbeat into dashboard

Shulou Source: shulou.com Published: 2022-06-03 05:38:19 10月04日 Update

Add a metricbeat to ELK stack 6.8.6 for fine-grained monitoring of system,kafka

The configuration file before the error is as follows:

# configuration added on the default basis

/ etc/metricbeat/metricbeat.yml

# = Modules configuration = reload.enabled: true#= Dashboards = setup.dashboards.enabled: truesetup.dashboards.url: "http://IP:5601"#==================== Kibana = = setup.kibana: host:" http://IP:5601"#==================== Ouputs = = output.elasticsearch: hosts: ["ES_IP:9200"]

Restart metricbeat after adding configuration

Restart OK

But cannot load dashboard

There is no journal for this problem, and it has been entangled for a long time, so it can only be reinstalled, and it turns out that

Just unregister the following two lines of configuration

# setup.dashboards.enabled: true#setup.dashboards.url: "http://IP:5601"

After restarting metricboard, import dashboard

# metricbeat setup-dashboard system

If the import is successful, enter kibana again, and you can see the imported dashboard.

You can see the system data after index

Tags: Configuration problem success again Foundation data File Log granularity system result Monitoring Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Redmi MariaDB Linux Huawei Microsoft