Get the App
SLTechnology News&Howtos  ›  Servers  › 

RHEL 7.0installs the pit that FTP stepped on

Shulou Source: shulou.com Published: 2022-06-03 06:33:50 09月21日 Update

The FTP server reported an error:

Q:

Job for vsftpd.service failed. See 'systemctl status vsftpd.service' and' journalctl-xn' for details.

A:

1. View the log journalctl-xn

2. Vim / etc/vsftpd/vsftpd.conf correction

The FTP client reports an error:

Q:

1 、 530 Login incorrect.

A:

1. Firewall iptables-F

2. SELinux planning

Getsebool-a | grep ftp

Setsebool-P ftpd_full_access=on

3. Configuration file vim / etc/vsftpd/vsftpd.conf

Anonymous_enable=NO

Local_enable=YES

Guest_enable=YES

Guest_eusername=virtual

Pam_service_name=vsftpd.vu

Allow_writeable_chroot=YES

User_config_dir=/etc/vsftpd/vusers_dir

Listen=YES # defaults to NO and changes to YES snooping

Listen_ipv6=NO # network environment does not support IPv6, change to NO or comment out

Tags: Customers clients files logs servers comments environment network firewall support services monitoring planning configuration fire prevention Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno NVidia Linux Shulou Tech Info Shulou Technology Microsoft