Exchange powershell error did not find any available global catalogs in the forest
An error occurs when the exchange powershell executes the relevant exchange command. No available global catalogs were found in the forest
This error will be reported regardless of any command executed. The screenshot is as follows
First of all, by checking the current site DC are working properly. Then, in order to force Exchange Server to redetect Active Directory sites and services topology,
Restart the Microsoft Exchange Active Directory Topology service on the Exchange server After the service restarts, the failure remains unresolved,
Subsequently, it was found that there was no problem in executing AD related commands, but executing the exchange command would report an error.
Finally, consider whether IIS has a problem, because the exchange shell command is invoked through IIS. Finally, IIS is restarted,
After the restart, the problem was finally solved.