Exchange 2013 2016 coexistence environment access 2016 reported HTTP 2016 error
Environment: exchange 2013 cu20
New to exchange 2016 cu11
Failure: log in to ex2016 ECP/OWA to report HTTP 500error
Login EX2016 EMS reported a lot of errors and a lot of garbled codes can not be logged in, login 2016 is not successful, automatically log in to 2013
Explanation: this fault lasted for more than half a month, all the tests were normal, the log did not report obvious errors, and all kinds of methods were tried (always felt related to IIS and web.config, but the ability was limited and the problem could not be found). Fortunately, I persisted and did not give up.
Key error message:
When I logged in to EMS again one morning, I found a message below. Send it with a try.
As follows:
Exchange IIS70Error=500,19,0x8007007e,9600
Search for this information with Baidu and open the first link with the attitude of a dead horse as a doctor:
Https://www.jb51.net/article/73170.htm
The contents are as follows:
HTTP error 500.19-Internal Server Error
The requested page cannot be accessed because the relevant configuration data for that page is invalid.
Detailed error message
Module DynamicCompressionModule
Notify SendResponse
Handler StaticFile
Error code 0x8007007e
Requested URL *
Physical path C:/ECG2.0/eWECGService
Login method anonymous
Login user anonymity
The most likely reason:
The worker process cannot read the applicationhost.config or web.config file.
A malformed XML exists in the applicationhost.config or web.config file.
The server cannot access the applicationhost.config or web.config file because of incorrect NTFS permissions.
Actions that can be tried:
Query the event log for information about why the configuration file is not readable.
Ensure that the user identity or authenticated user specified for the application pool has the necessary permissions to access the web.config file.
I searched the Internet for a long time and found that it was not a matching error. Finally found it on an English website.
Solution:
# Remove/Disable the XPress compression scheme from the configuration using the command below: (the following command is fine in Dos)
The code is as follows:
% windir%/system32/inetsrv/appcmd.exe set config-section:system.webServer/httpCompression /-[name='xpress']
Original post address: http://blogs.msdn.com/b/webtopics/archive/2010/03/08/troubleshooting-http-500-19-errors-in-iis-7.aspx
Everything is fine after running the code above.
Feeling: although it took a long time to solve this problem, I was not happy at all. They are more worried about their own lack of knowledge reserves.
PS: during the migration of mailbox users, it is found that the AUDITLOG parameters are not recognized (including normal exchange2013). After this problem is resolved, this problem is fine.