Get the App
SLTechnology News&Howtos  ›  Servers  › 

MapiExceptionTooComplex: Unable to query table row

Shulou Source: shulou.com Published: 2022-06-02 16:54:29 10月04日 Update

In a recent project, a batch of accounts from Exchange2010 migrated mailbox to Exchange2016 server reported an error that could not be migrated.

The error report is as follows:

Error code:-2146233088

Unable to query rows in the table. -- rows. (hr=0x80040117, ec=-2147221225)

Diagnostic context:

Lid: 55847 EMSMDBPOOL.EcPoolSessionDoRpc called [length=206]

Lid: 43559 EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0] [length=379] [latency=0]

Lid: 52176 ClientVersion: 15.0.516.30

Lid: 50032 ServerVersion: 15.0.516.6030

Lid: 23226-ROP Parse Start-

Lid: 27962 ROP: ropGetContentsTableExtended [164]

Lid: 27962 ROP: ropSetColumns [18]

Lid: 27962 ROP: ropRestrict [20]

Lid: 17082 ROP Error: 0x80040117

Lid: 27489

Lid: 21921 StoreEc: 0x80040117

Lid: 27962 ROP: ropExtendedError [250]

Lid: 1494-Remote Context Beg-

Lid: 37736 dwParam: 0x300B0102

Lid: 55288 StoreEc: 0x80040117

Lid: 63016 dwParam: 0x14

Lid: 39640 StoreEc: 0x80040117

Lid: 10786 dwParam: 0x0 Msg: 15.00.0516.025:CSTCS83

Lid: 1750-Remote Context End-

Lid: 27962 ROP: ropQueryRows [21]

Lid: 17082 ROP Error: 0x80040117

Lid: 17153

Lid: 21921 StoreEc: 0x80040117

Lid: 27962 ROP: ropExtendedError [250]

Lid: 1494-Remote Context Beg-

Lid: 37736 dwParam: 0x300B0102

Lid: 55288 StoreEc: 0x80040117

Lid: 63016 dwParam: 0x14

Lid: 39640 StoreEc: 0x80040117

Lid: 10786 dwParam: 0x0 Msg: 15.00.0516.025:CSTCS83

Lid: 60464 dwParam: 0x80040117

Lid: 10786 dwParam: 0x0 Msg: 15.00.0516.025:CSTCS83

Lid: 1750-Remote Context End-

Lid: 26849

Lid: 21817 ROP Failure: 0x80040117

Lid: 28414

Lid: 32510 StoreEc: 0x80040117

Context:

Operation: StorageDestinationFolder.ApplyRestriction

Restriction: Restriction: LCID=0x804, CONTENT [ptag:SearchKey, IgnoreCase, val: [Tag:SearchKey, Value:cb = 16, lpb = B67E2F3C146EAB4EBEF5E9733AE1387E]]

Context:

Operation: StorageDestinationFolder.ApplyRestriction

Restriction: Restriction: LCID=0x804, CONTENT [ptag:SearchKey, IgnoreCase, val: [Tag:SearchKey, Value:cb = 16, lpb = B67E2F3C146EAB4EBEF5E9733AE1387E]]

Operation: IDestinationMailbox.CreateFolder

OperationSide: Target

Master (ce559432-9615-4f30-8501-7d7c4518a7a2)

Folder: 'inbox', entryId [len=46, data=000000001AB46D81E82D444394ABA21AE663DDAA0100E0CD58E5E5F7FC448AFBF4737DA37BAF0000016C21D10000], parentId [len=46, data=000000001AB46D81E82D444394ABA21AE663DDAA0100E0CD58E5E5F7FC448AFBF4737DA37BAF0000016C21CE0000]

FailIfExists: False

Folder:'/ Top of Information Store/ Inbox', entryId [len=46, data=000000001AB46D81E82D444394ABA21AE663DDAA0100E0CD58E5E5F7FC448AFBF4737DA37BAF0000016C21D10000], parentId [len=46, data=000000001AB46D81E82D444394ABA21AE663DDAA0100E0CD58E5E5F7FC448AFBF4737DA37BAF0000016C21CE0000]

According to the official document https://support.microsoft.com/en-us/help/3057422/mapiexceptionnoaccess-unable-to-query-table-rows-error-and-some-mailbo, problems with upgrading from Exchange2010 to RU10 still occur.

Finally, it is solved in the following ways:

Tags: Context inbox code content official document method server query table account mailbox error problem project upgrade service query Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Xiaomi OPPO Reno NVidia Docker Shulou Technology