Interesting FTP error in Solaris 10-ROOT cannot access F
Interesting FTP error in Solaris 10-ROOT cannot access FTP
System environment:
Operating system: Solaris 10
Error phenomenon:
[root@solaris187:/] # ftp 127.0.0.1
Connected to 127.0.0.1.
220 solaris187 FTP server ready.
Name (127.0.0.1:root): root
331 Password required for root.
Password:
530 Login incorrect.
Login failed.
Root users cannot access ftp, other users can!
Case study:
It defaults to security under Solaris. Root users are prohibited from accessing ftp and are restricted through the / etc/ftpusers file.
If the root user is removed from this file, the root user can access the ftp, but this case still cannot!
Case study:
1. If it is a profile restriction, it should be that the root user does not have the opportunity to enter the password and is directly rejected.
2. You can enter a password to indicate that the authentication identity is wrong; it may be a password or / etc/passwd file problem.
Troubleshoot the password and view the / etc/passwd file:
[root@solaris187:/] # cat / etc/passwd
Root:x:0:0:Super-User:/:usr/bin/bash
Daemon:x:1:1::/:
Bin:x:2:2::/usr/bin:
Sys:x:3:3::/:
Adm:x:4:4:Admin:/var/adm:
Lp:x:71:8:Line Printer Admin:/usr/spool/lp:
Uucp:x:5:5:uucp Admin:/usr/lib/uucp:
Nuucp:x:9:9:uucp Admin:/var/spool/uucppublic:/usr/lib/uucp/uucico
Smmsp:x:25:25:SendMail Message Submission Program:/:
Listen:x:37:4:Network Admin:/usr/net/nls:
Gdm:x:50:50:GDM Reserved UID:/:
Webservd:x:80:80:WebServer Reserved UID:/:
Postgres:x:90:90:PostgreSQL Reserved UID:/:/usr/bin/pfksh
Svctag:x:95:12:Service Tag UID:/:
Nobody:x:60001:60001:NFS Anonymous Access User:/:
Noaccess:x:60002:60002:No Access User:/:
Nobody4:x:65534:65534:SunOS 4.x NFS Anonymous Access User:/:
Tom:x:500:500::/export/home/tom:/bin/bash
Bob:x:501:500::/export/home/bob:/bin/bash
Unexpectedly, it was found that in the entry of the root user, the shell part was missing a "/" before the usr, so that shell could not be enabled!
Change to:
Root:x:0:0:Super-User:/:/usr/bin/bash
@ so far, the problem is solved!