How to solve the kubernetes startup error (Unable to connect to the server: x509: certificate signed by unknown authority)
This article mainly introduces how to solve Kubernetes startup error (Unable to connect to the server: x509: certificate signed by unknown authority ), which has certain reference value. Take a look at it with me.
Kubernetes started with the following error:
Unable to connect to the server: x509: certificate signed by unknown authority (possibly because of "crypto/rsa: verification error" while trying to verify candidate authority certificate "kubernetes")
What is the reason for this error? It's possible that I forgot to execute the script.
1. mkdir -p $HOME/.kube
2.sudo cp -i /etc/kubernetes/admin.conf $HOME/.kube/config
3.sudo chown $(id -u):$(id -g) $HOME/.kube/config
As long as the script program is executed, it will be normal
1. [root@worker3 shell]# kubectl get node
2. NAME STATUS ROLES AGE VERSION
3. worker3 Ready master 1m v1.10.0 or above is Kubernetes startup error (Unable to connect to the server: x509: certificate signed by unknown authority ) How to solve the details of the content, after reading whether there is any harvest? If you want to know more, welcome to the industry news!