Use openstack local source installation to report an error
When installing using openstack (version OpenStack-Rocky) local source, a missing installation package was found to report ERRO. The error is as follows
Pre installing Puppet and discovering hosts' details [ERROR] ERROR: Failed to run remote script, stdout: Loaded plugins: fastestmirror ·stderr: Warning: Permanently added '192.168.100.11' (ECDSA) to the list of known hosts.+ trap t ERR+ yum install-y puppet hiera openssh-clients tar nc rubygem-jsonError: Package: 2:nmap-ncat-6.40-16.el7.x86_64 (openstack) Requires: libpcap.so.1 () (64bit) + + tweets + exit 1
Solution.
Mounting the local system CD and building a local yum source can solve the problem.