Multipath error reporting: Cannot open PowerPath. Initialization error
Suse 11 sp4 install powerpath 6.1x restart and execute command prompt to report an error:
Shell > powermt display dev=all
Powermt commands are failing with "ERROR: Cannot open PowerPath. Initialization error"
Resolve step 1:
Find a post through the official website: https://community.emc.com/docs/DOC-67557 found that this is a bug
Solution:
Use the following command on the host to update hwclock to the system clock:
Hwclock-systohc
This updates the hardware clock to the correct time on the host. Permanent fix: this issue will be fixed in PowerPath for Linux 6.3
After following the operation, it failed to start normally:
Resolve step 2:
Shell > cat / var/log/boot.log | grep PowerPath # check the log and find that the service has been stopped in China during the startup process
Shell > / etc/init.d/PowerPath start # Manual restart prompt DM-Multipath is active
Starting PowerPath: Aborting PowerPath start since DM-Multipath is active. Refer to PowerPath for Linux Installation and Administration Guide for more information
Failed
Resolve step 3
Since it is because: "start PowerPath: because DM Multipath is active, aborting PowerPath startup", then stop and try, then restart the system, restart multipath after entering the system, the problem is solved.
Shell > service multipathd stop
Stopping multipathd daemon: [OK]
Shell > chkconfig multipathd off
Shell > / etc/init.d/multipathd status
Multipathd is stopped
Shell > mpathconf-- disable
Reboot
Shell > / etc/init.d/PowerPath start
Starting PowerPath: done
Shell > powermt display dev=all