How to solve the problem that linux system starts weblogic managed server to report Socket closed
This article shows you how to solve the problem of linux system starting weblogic managed server unable to get file lock, will ret_daring, the content is concise and easy to understand, it will definitely brighten your eyes. I hope you can get something through the detailed introduction of this article.
When the linux system starts the weblogic managed server and reports the following error:
Solution: enter cd Middleware/ and use find. The-name * .lok command finds the file and then deletes it.
Example: rm. / user_projects/domains/base_domain/servers/pc-linux01/tmp/pc-linux01.lok
Linux system starts weblogic managed server and reports Socket closed error
When the linux system starts the weblogic managed server and reports the following error:
Multicast socket receive error: java.net.SocketException: Socket closed
……
Java.io.IOException: Invalid argument
Solution:
Open the startManagedWebLogic.sh file under / home/weblogic/Oracle/Middleware/user_projects/domains/base_domain/bin and find the
JAVA_OPTIONS= "- Dweblogic.security.SSL.trustedCAKeyStore=" / home/weblogic/Oracle/Middleware/wlserver_10.3/server/lib/cacerts "${JAVA_OPTIONS}"
Modify to
JAVA_OPTIONS= "- Dweblogic.security.SSL.trustedCAKeyStore=" / home/weblogic/Oracle/Middleware/wlserver_10.3/server/lib/cacerts "${JAVA_OPTIONS}-Djava.net.preferIPv4Stack=true"
The above content is how to solve the problem that the linux system starts the weblogic managed server to report unable to get file lock and will ret_daring. Have you learned the knowledge or skills? If you want to learn more skills or enrich your knowledge reserve, you are welcome to follow the industry information channel.