Get the App
SLTechnology News&Howtos  ›  Servers  › 

WSUS console frequently reports errors: connection error

Shulou Source: shulou.com Published: 2022-06-03 08:03:34 10月03日 Update

The WSUS console reports an error and prompts a connection error. By clicking to reset the server node, you can occasionally return to normal, and restart the WSUS Service service immediately, but connection failures still occur frequently.

Check the application log to find the following large number of error logs, Windows Server Update Services event ID:7032,13042,12002,12012,12032,12052,12072,12022,12042.

In addition, it also includes the WAS event ID:5138,5013,5002 in the administrative view.

The following is a partial error log:

After checking, the WsusPool application pool in IIS automatically stops and starts it back to normal.

Root cause of failure: the default "dedicated memory limit" of IIS's application pool is 1.8 GB of memory, and Quick fail Prevention is enabled, but the WSUS update reaches a certain scale, and the default allocated memory no longer meets the needs, causing the worker process to crash and finally trigger the WsusPool application pool to shut down.

Solution: just increase the memory according to the actual needs.

Open IIS Manager-Application Pool, find WsusPool, click Advanced Settings on the right, and change the memory to a reasonable value such as 4GB in the dedicated memory limit item. This operation can also optimize the running experience of the WSUS console. Or change the memory entry to 0 (unlimited) and turn off Quick fail Protection.

Command version:

"c:\ Windows\ System32\ inetsrv\ appcmd.exe" set apppool / apppool.name:wsuspool / recycling.periodicRestart.privateMemory: "4096000"c:\ Windows\ System32\ inetsrv\ appcmd.exe" set apppool / apppool.name:wsuspool / failure.rapidFailProtection: "false"c:\ Windows\ System32\ inetsrv\ appcmd.exe" list apppool "wsuspool" / text:*

Reference and reprint:

TechNet blog: WSUS server frequently reports errors: connection failure

WSUS console error: WsusPool application stopped

Tags: Memory application program application fault console control log service limit frequency error event server dedicated inspection management protection advanced lieutenant general Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Microsoft Linux Redmi MariaDB Shulou Technology