Get the App
SLTechnology News&Howtos  ›  Servers  › 

VCSA 6.5 cannot be accessed, the solution to "503 Service Unavailable" was reported.

Shulou Source: shulou.com Published: 2022-06-02 23:28:46 10月04日 Update

When accessing VCSA, it suddenly crashes and cannot be refreshed, but you can ping VCSA. After a long time, refresh the browser with the following error:

503 Service Unavailable (Failed to connect to endpoint: [N7Vmacore4Http20NamedPipeServiceSpecE:0x0000558181b429e0] _ serverNamespace = / action = Allow _ pipeName = / var/run/vmware/vpxd-webserver-pipe)

While we were looking for a solution, we suddenly stopped reporting this error and reported another similar error, as follows:

503 Service Unavailable (Failed to connect to endpoint: [N7Vmacore4Http16LocalServiceSpecE:0x00007fbd38074bd0] _ serverNamespace = / vsphere-client action = Allow _ port = 9090)

Solution:

Use SSH to log in to VCSA to view and resolve the problem.

VMware vCenter Server Appliance 6.5.0.14000Type: vCenter Server with an embedded Platform Services ControllerConnected to service * List APIs: "help api list" * List Plugins: "help pi list" * Launch BASH: "shell" Command > shell # using shell to connect Shell access is granted to rootroot@photon-machine [~] # root@photon-machine [~] # service -control-- help # View VMware services help root@photon-machine [~] # root@photon-machine [~] # service-control-- list-services # list all controllable VMware services root@photon-machine [~] # root@photon-machine [~] # service-control-- status vsphere-client # View VMware services running status Stopped: vsphere-clientroot@photon-machine [~] # service-control-- start vsphere-client # start vsphere-clientPerform start operation. Vmon_profile=None, svc_names= ['vsphere-client'], include_coreossvcs=False, include_leafossvcs=False2018-03-17T16:19:28.015Z Service vsphere-client state STOPPEDSuccessfully started service vsphere-clientroot@photon-machine [~] # service-control-status vsphere-clientRunning: vsphere-client

Vmware-vpxd vmware-eam vmware-invsvc

The local IP needs to connect to the ports required by the host EXSI management IP and Vcenter management IP

Tags: Error method management same class host host time being browser status port problem native help service browse login run Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Shulou Technology MySQL macOS Microsoft MariaDB