Get the App
SLTechnology News&Howtos  ›  Servers  › 

The Exchange service failed to start case sharing

Shulou Source: shulou.com Published: 2022-06-02 19:17:57 09月22日 Update

Today, I shared two cases where Exchange service could not be started. The nature of the case was consistent with the appearance of the problem. I wrote it on a blog, hahaha.

Case 1: Earlier, one of our customers reported that the Exchange2010 server in the production environment was infected with a virus. After comprehensive disinfection of the server, it was found that all Exchange2010 servers in the domain could not start the service normally. We began to suspect that the server did not restart normally and the latest Exchange patch could not be updated. The following is the investigation process:

1. Try to restart Exchange topology service manually, and the error is as follows:

2. Check the system log and find a large number of 2080 logs;

3. Found SACL permission lost

Add SACL permissions to Exchange in GPO

5. Refresh the group policy and observe that the 2080 event has slowly returned to normal.

6. Each mail server has been automatically started.

Case 2: A customer in June, also a production environment mailbox, suddenly said that all mailboxes, mobile phones, and OWA could not be used. Check that the server disk space is normal, the database is normally mounted, and Exchange-related services cannot be started normally. According to the idea of the previous case, carry out the same investigation process;

1. Check the system log

2. Check that the group policy SACL permissions are normal;

3. Re-extend domain architecture using Exchange mirroring

4. Refresh group policy, topology service log has been restored

5. Check the mail server and it has returned to normal.

Summary: The above two cases, discussed afterwards, should be able to repair through the extended domain architecture, the principle of which is not clear, free to study again.

Tags: Service server case inspection log permission policy two customer topology architecture environment system process mail mailbox production consistent elusive event Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno vpn Xiaomi Microsoft MySQL Linux