LINUX SSH mutual trust and user's home directory permissions
Recently, another Oracle database was deployed on two Oracle RAC cluster servers. DBCA reported that the cluster nodes were inaccessible when the database was built, but the existing cluster was indeed working normally. After troubleshooting, it is found that the oracle home directory permission is set to 777, and the abnormal node oracle home directory is set to another node home directory permission 755, and then the normal operation is restored.
1. Oracle rac 2 node cluster. Oracle user DBCA reports an error when building the database:
If you click yes to continue, OUI reports an error and cannot continue:
2. Problem analysis
Follow the OUI prompt to check whether the cluster nodes rac1 and rac2 are interconnected. There is no problem with network interconnection. Otherwise, the existing database cluster cannot work normally:
Check the mutual trust between nodes, grid mutual trust is not a problem, but oracle mutual trust is not:
As shown in the figure, oracle database cluster users oracle mutual trust prompt requires password, and later rebuilt the mutual trust problem of oracle users between nodes still exists.
Checking the node rac1 operating system log found no exceptions:
Check/var/log/secure logs and find node1 log prompt/home/oracle host group permission problem:
Check that oracle home directory permissions for node 1 are 777:
Compare the oracle home directory permissions of node 2 with 755:
3. Problem solving
After finding the root cause of the problem, the problem is handled very simply, that is, the oracle home directory permission of node rac1 is modified to 755, and the problem is solved:
Oracle can proceed smoothly:
Postscript: 3 possible reasons for LINUX/UNIX trust failure:
1. Mutual trust related user home directory permissions are too high, such as 777
The requested URL/home/oracle/was not found on this server.
3. Operating system firewall impact