Windows cannot start IIS Admin Service on the local computer
Specific error message:
Windows cannot start IIS Admin Service on the local computer. For more information, consult the system event log. If this is a non-Microsoft service, contact the service vendor and refer to service-specific error code-2145318902.
Reason for error:
C:\Windows\System32\inetsrv\MetaBase.xml This file has a problem
Solution:
Delete the file C:\Windows\System32\inetsrv\MetaBase.xml
Go to C:\Windows\System32\inetsrv\History folder and copy a copy of the most recent valid MetaBase_*_*.xml to C:\Windows\System32\inetsrv, then rename it to MetaBase.xml, and then start IIS Admin Service, which starts normally.