Get the App
SLTechnology News&Howtos  ›  Servers  › 

Windows cannot start IIS Admin Service on the local computer

Shulou Source: shulou.com Published: 2022-06-03 05:00:29 09月21日 Update

Specific error message:

Windows cannot start IIS Admin Service on the local computer. For more information, consult the system event log. If this is a non-Microsoft service, contact the service vendor and refer to service-specific error code-2145318902.

Reason for error:

C:\Windows\System32\inetsrv\MetaBase.xml This file has a problem

Solution:

Delete the file C:\Windows\System32\inetsrv\MetaBase.xml

Go to C:\Windows\System32\inetsrv\History folder and copy a copy of the most recent valid MetaBase_*_*.xml to C:\Windows\System32\inetsrv, then rename it to MetaBase.xml, and then start IIS Admin Service, which starts normally.

Tags: Services files errors information computers validity events codes methods vendors reasons copies folders logs right and wrong more systems problems references related Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Microsoft OPPO Reno Apple MySQL macOS